Backup Performance

Incident Report for m109

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 00:01 UTC

Investigating

We are actively investigating an issue causing degraded backup performance. This may impact all backup jobs across all agents. Our team is working to identify the root cause and restore normal operations as quickly as possible.
We will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Dec 16, 2025 - 14:18 UTC
This incident affected: Web Portal (East US2).