Degraded backup performance

Incident Report for m109

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 13:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 23:11 UTC

Update

We are continuing to investigate this issue.
Posted Apr 17, 2026 - 13:23 UTC

Investigating

Some customers may be experiencing degraded backup performance, which could impact backup SLAs. Our engineering team is actively investigating and taking steps to restore full performance.
Posted Apr 16, 2026 - 14:34 UTC
This incident affected: File & Object (East US2, Canada Central).