Backup performance degradation

Incident Report for m109

Resolved

Commvault Cloud performance has remained stable following the corrective actions taken by our engineering teams. After an extended period of monitoring, this incident has been fully resolved.

Thank you for your patience and partnership while we worked to restore normal service.
Posted Jul 14, 2026 - 15:41 UTC

Update

We completed an infrastructure upgrade to the operating systems supporting our US and Canada network proxies. No service disruption was expected, and backup operations should not have been affected.
Posted Jul 06, 2026 - 14:28 UTC

Update

On Saturday 6/27, we performed a restart of a core control plane service to resolve a service responsiveness issue. During the restart, some backup jobs may have been temporarily interrupted. The service was restored shortly after and has been operating normally since. We are actively monitoring the environment, and no ongoing impact has been observed.
Posted Jun 30, 2026 - 22:05 UTC

Update

We will be deploying a control plane update within the next 30 minutes to address the stalled operations that were observed. The deployment is expected to complete in under five minutes, and we will continue to closely monitor system performance afterward.
Posted Jun 24, 2026 - 20:09 UTC

Monitoring

Backup operations and overall system performance continue to run normally. During ongoing monitoring and analysis, our engineering team identified a potential edge-case condition that may have affected the progression of a small number of backup jobs last week. We remain actively engaged in monitoring and implementing improvements to help prevent similar occurrences in the future.
Posted Jun 23, 2026 - 18:08 UTC

Update

Backup operations have largely stabilized over the course of the day, and we are continuing to closely monitor the environment. Our investigation into the earlier disruption is ongoing to better understand the underlying cause.
Posted Jun 19, 2026 - 22:07 UTC

Investigating

Some customers may be experiencing degraded backup performance, which could impact backup SLAs. Our engineering team is actively investigating and taking steps to restore full performance.
Posted Jun 19, 2026 - 15:04 UTC
This incident affected: Web Portal (East US2).