Degraded Connectivity Between Azure and AWS Data Planes

Incident Report for m109

Resolved

The connectivity has been fully restored.
Posted Sep 14, 2026 - 17:27 UTC

Monitoring

We are currently experiencing degraded connectivity between the Azure and AWS data planes. Our engineering teams are actively investigating the issue and working to restore full connectivity.
We will provide further updates as more information becomes available.
Posted Sep 13, 2026 - 15:07 UTC
This incident affected: VM & Kubernetes (East US2, Canada Central) and File & Object (East US2, Canada Central).